Luminor (EE) - Major Outage

Incident Report for Tink providers Baltics

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Oct 13, 2025 - 10:32 EEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2025 - 14:15 EEST

Investigating

We are currently investigating an issue with Luminor (EE).
Posted Sep 25, 2025 - 11:32 EEST
This incident affected: Luminor (EE).