SEB - Open Banking - Major outage affect Payment Initiation
Incident Report for Tink providers Baltics
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Dec 05, 2024 - 13:46 UTC
Identified
We have identified the issue and we will update when a significant change to the situation occurs.
Posted Nov 29, 2024 - 13:33 UTC
This incident affected: SEB (EE), SEB (LT), and SEB (LV).