Swedbank[LT] Open Banking - Major outage affecting Payment Initiation services
Incident Report for Tink providers Baltics
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 16:39 UTC
Investigating
We are currently investigating an issue with Swedbank.
Posted Apr 29, 2023 - 10:45 UTC
This incident affected: Swedbank (EE) and Swedbank (LT).