Swedbank - Major outage affecting Account Information and Payment Initiation services

Incident Report for Tink providers Baltics

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jul 26, 2025 - 05:44 UTC

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Jul 25, 2025 - 13:21 UTC
This incident affected: Swedbank (EE), Swedbank (LT), and Swedbank (LV).