EE - LHV Open Banking - Major Outage
Incident Report for Tink providers Baltics
Resolved
This incident has been resolved.
Posted Oct 31, 2023 - 09:52 UTC
Investigating
We are currently investigating an issue with [Bank Name].
Posted Oct 30, 2023 - 15:11 UTC
This incident affected: LHV (EE).