EE LHV Open Banking - Bug for Payment Service - Degraded Performance

Incident Report for Tink providers Baltics

Resolved

The issue has been resolved. We apologize for the inconvenience.
Posted Mar 27, 2025 - 15:27 UTC

Investigating

We are currently investigating a bug for EE LHV Open Banking. Successful payments can be shown as failed.
Posted Mar 25, 2025 - 09:39 UTC
This incident affected: LHV (EE).