Revolut (LT) Open Banking - Major outage with Account information and Payments
Incident Report for Tink providers Baltics
Resolved
This issue has been resolved. We apologize for the inconvenience.
Posted Nov 06, 2023 - 09:11 UTC
Identified
We have identified the issue and are in contact with Revolut for further information.
We will update when a significant change to the situation occurs.
Posted Oct 26, 2023 - 13:16 UTC
This incident affected: Revolut (LT).